Commander Echo Instrument Potential Problems

Problem

Probable Cause

Possible Solution

Instrument does not appear to respond to the charger. The LED does not light. 

Bad Connection or Inoperable Battery 

Check the USB daisy chain connection to the charger and the instrument. If the daisy chain connections appear to be good, remove all other devices and try connection the instrument to a different USB connection on the USB dais chain.  If the LED does not light up after 60 minutes, contact JTECH Customer Service for repair options.

The enter button will no longer click when pressed. 

Possible damaged switch 

Please contact JTECH Support for repair options 

Instrument LED blinks rapid RED and then stos after a few seconds on any attempt to turn the instrument on. 

Dead battery Indicator 

Charge the instrument for one complete cycle (up to 6 hours) and attempt to use it again. 

Add a Comment

Help Us Improve!

While perusing our support articles, if you find an article confusing or you feel it could be written better, just click add a comment and leave your concerns.  

Our Customer Service department will attempt to address your concerns as soon as possible.  Thank you for helping JTECH help you☺