Commander Echo™ Console Potential Problems

Problem

 

Probable Cause

 

Possible Solution

The Windows “Found New Hardware process is triggered when the Console is connected via USB.

 

First time installation of plugging the Console into a different USB port.

 

Please select yes, install, or continue as this is expected behavior and should be allowed to run.  No specified drivers are included as Windows includes the default drivers.

Console does not appear to respond to the charger. The green-colored LED does not light.

 

Bad connection or Inoperable battery

 

Check the USB daisy chain connection to the charger and the Console.  If the daisy chain connections appear to be good, remove all other devices and try connecting the Console to a different USB connection on the USB daisy chain.  If the LED does not light up after 60 minutes, contact JTECH Customer Service for repair options.

The control stick will no longer click when pressed.

 

Possible damaged switch.

 

Please contact JTECH Support for repair options.

Console LED blinks rapid red and does not stop.

 

Dead battery Indicator.

 

Charge the Console for one complete cycle (up to 6 hours) and attempt to use it again.

Console does not turn on and the LED does not blink when trying to turn one.

 

The Console software has locked up or the battery charge is fully depleted.

 

Use a paperclip to press the reset switch on the backside of the Console.  If the Console still does not turn on, connect the Console to the charger for 1 hour. If the Console turns on after 1 hour allow the Console to continue charging.  Otherwise contact JTECH support for repair options.